Telephone Communication Issue

Major Incident Phone Communication System
1 hour, 4 minutes

Update

Resolved

Top Priority Service has been recovered successfully. TEX are able to make and receive calls properly. Gurus are only able to make and receive calls from Company Presents.

Feb 6th, 2019 11:54 CST
Investigating

Minor Progress. Main Phone Number 1-877-659-4470 is able to connect to Guru’s and TEX.

Feb 6th, 2019 11:51 CST
Issue

We are currently experiencing a Telephone Communication Issue. This issue has interrupted our Phone Communication System to our Guru’s and Team of Experts.

Feb 6th, 2019 10:53 CST