Direct Dial is Unavailable

Minor incident Phone Communication System
2019-02-06 11:54 CDT · 1 week, 4 days, 4 hours, 40 minutes

Updates

Resolved

We have successfully resolved this issue. All Team of Expert’s and Guru’s are able to make and receive calls.

February 17, 2019 · 16:34 CDT
Investigating

Agents are unable to receive incoming calls from direct dialing numbers. Please use 1-877-659-4470 for the time being. We are working hard to resolve this issue. ETA is undetermined at this time.

February 6, 2019 · 11:58 CDT

← Back